802.11n i VPLS - remedium na kulawy WDS

Posted on czw 21 kwiecień 2011 in MikroTik

Jak nowe gryzie się ze starym

MikroTik RouterOS, 802.11n i WDS. To niestety nie działa, przynajmniej nie tak jak powinno. Krótko rzecz ujmując - nie osiągniemy pełnej prędkości 802.11n w przypadku gdy korzystamy z WDS. Powodem jest brak wsparcia dla agregacji stosowanej w "ence", a która znacząco wpływa na wydajność połączenia. Czy zatem wybór jaki na pozostał to brak WDS (zapominamy o przeźroczystych mostach) lub brak możliwości skorzystania z dobrodziejstw nowej technologii? Na szczęście nie.

And now for something completely different

Ratunek nadchodzi z zupełnie niespodziewanej strony MPLS (Multi Protocol Label Switching). Można by wiele napisać na temat MPLS (książki na ten temat są naprawdę grube!), jednak my skupimy się na jednym, niewielkim, ale jak się okazuje, niezwykle ważnym elemencie - VPLS. Jednym słowem - pokażemy remedium na problem jaki został zasygnalizowany w pierwszym akapicie bez zagłębiania się w istotę MPLS (może innym razem ;)).

Najpierw rzut oka na topologię.

Tunel
VPLS

Jeden z routerów konfigurujemy jak Ap-bridge, drugi jako station (nie dotykamy WDS). Połączenie pomiędzy nimi adresujemy w innej podsieci niż ta, którą chcemy połączyć. W naszym przykładzie jest to 10.0.0.0/30. Następnie skonfigurujemy interfejsy VPLS i dodamy je jako porty interfejsów bridge. Efektem będzie przeźroczyste połączenie pomiędzy dwiema częściami sieci 192.168.88.0/24 - z pełną prędkością 802.11n.

Do dzieła.

[admin@R1] > /interface bridge add name=loopback
[admin@R1] > /ip address add address=1.1.1.1/32 interface=loopback
[admin@R1] > /ip route add dst-address=2.2.2.2/32 gateway=10.0.0.2
[admin@R1] > /mpls ldp set lsr-id=1.1.1.1 transport-address=1.1.1.1 \ 
         enabled=yes
[admin@R1] > /mpls ldp interface add interface=wlan1

W wierszu pierwszym dodaliśmy interfejs bridge bez portów - taki interfejs jest zawsze podniesiony - będzie nam potrzebny jako lsr-id (identyfikator routera) oraz transport-address (adres do którego łączyć się będzie druga strona).

Na kolejnym routerze konfiguracja będzie analogiczna, użyjemy jednak adresu 2.2.2.2. Ponieważ ten adres musi być osiągalny, musimy dodać trasę statyczną (lub dystrybuować go protokołem routingu) - robimy to wierszy trzecim.

Następnie musimy uruchomić silnik protokołu LDP. Potrzebny nam będzie do prawidłowego działania VPLS. W ostatnim kroku wskazujemy na którym interfejsie LDP ma szukać sąsiadów.

Kolejnym krokiem jest skonfigurowanie interfejsów VPLS. Jak wspomniałem, nie będziemy się zagłębiać w istotę MPLS/VPLS, na tym etapie wystarczy nam fakt, że obie końcówki tunelu VPLS muszą posiadać ten sam ID - w tym przykładzie 0:1.

[admin@R1] > /interface vpls add remote-peer=2.2.2.2 vpls-id=0:1   
       mac-address=000000000010

Analogicznie na routerze R2.

[admin@R2] > /interface vpls add remote-peer=1.1.1.1 vpls-id=0:1   
       mac-address=000000000020

Pozostaje nam utworzyć kolejny interfejs bridge. Tym razem dodamy porty: ether1 i vpls1.

[admin@R1] > /interface bridge add
[admin@R1] > /interface bridge ports add bridge=bridge1 interface=ether1
[admin@R1] > /interface bridge ports add bridge=bridge1 interface=vpls1
[admin@R1] > /ip address add interface=bridge1 address=192.168.88.1/24

Analogicznie postępujemy na routerze R2.

Gotowe.

Poniżej link do pliku z konfiguracją. Wystarczy skonfigurować interfejsy wlan i dostosować adresację.

vpls-config.rsc

FIN